source: branches/2.5/phpgwapi/setup/tables_update.inc.php @ 7917

Revision 7917, 6.3 KB checked in by douglas, 7 years ago (diff)

Ticket #3356 - Problema ao utilizar o expresso com IPv6

  • Property svn:eol-style set to native
  • Property svn:executable set to *
Line 
1<?php
2        /**************************************************************************\
3        * phpGroupWare - Setup                                                     *
4        * http://www.phpgroupware.org                                              *
5        * --------------------------------------------                             *
6        *  This program is free software; you can redistribute it and/or modify it *
7        *  under the terms of the GNU General Public License as published by the   *
8        *  Free Software Foundation; either version 2 of the License, or (at your  *
9        *  option) any later version.                                              *
10        \**************************************************************************/
11
12        // Since Expresso 1.2 using API EgroupWare 1.0.0.007
13        $test[] = '1.0.0.007';
14        function phpgwapi_upgrade1_0_0_007()
15        {
16
17                global $setup_info,$phpgw_setup;
18
19                $phpgw_setup->oProc->AddColumn('phpgw_access_log','browser', array ('type' => 'varchar', 'precision' => 200));
20                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '1.0.0.008';
21                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
22
23        }
24       
25        $test[] = '1.0.0.008';
26        function phpgwapi_upgrade1_0_0_008()
27        {
28                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.0.pre-alpha';
29                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
30
31        }
32
33        $test[] = '2.0.0.pre-alpha';
34        function phpgwapi_upgrade2_0_0_prealpha()
35        {
36                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.000';
37                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
38        }
39        $test[] = '2.0.000';
40        function phpgwapi_upgrade2_0_000()
41        {
42                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.001';
43                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
44        }
45        $test[] = '2.0.001';
46        function phpgwapi_upgrade2_0_001()
47        {
48                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.002';
49                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
50        }               
51        $test[] = '2.0.002';
52        function phpgwapi_upgrade2_0_002()
53        {
54                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.003';
55                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
56        }
57        $test[] = '2.0.003';
58        function phpgwapi_upgrade2_0_003()
59        {
60                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.004';
61                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
62        }
63        $test[] = '2.0.004';
64        function phpgwapi_upgrade2_0_004()
65        {
66                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.005';
67                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
68        }
69        $test[] = '2.0.005';
70        function phpgwapi_upgrade2_0_005()
71        {
72                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.006';
73                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
74        }                       
75        $test[] = '2.0.006';
76        function phpgwapi_upgrade2_0_006()
77        {
78                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.007';
79                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
80        }       
81        $test[] = '2.0.007';
82        function phpgwapi_upgrade2_0_007()
83        {
84                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.008';
85                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
86        }       
87        $test[] = '2.0.008';
88        function phpgwapi_upgrade2_0_008()
89        {
90                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.009';
91                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
92        }
93        $test[] = '2.0.009';
94        function phpgwapi_upgrade2_0_009()
95        {
96                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.0.010';
97                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
98        }       
99        $test[] = '2.0.010';
100        function phpgwapi_upgrade2_0_010()
101        {
102                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.1.000';
103                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
104        }       
105        $test[] = '2.1.000';
106        function phpgwapi_upgrade2_1_000()
107        {
108                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.000';
109                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
110        }
111        $test[] = '2.2.000';
112        function phpgwapi_upgrade2_2_000()
113        {
114                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.1';
115                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
116        }
117        $test[] = '2.2.1';
118        function phpgwapi_upgrade2_2_1()
119        {
120                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.2';
121                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
122        }
123        $test[] = '2.2.2';
124        function phpgwapi_upgrade2_2_2()
125        {
126                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.3';
127                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
128        }
129        $test[] = '2.2.3';
130        function phpgwapi_upgrade2_2_3()
131        {
132                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.4';
133                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
134        }
135        $test[] = '2.2.4';
136        function phpgwapi_upgrade2_2_4()
137        {
138                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.6';
139                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
140        }
141        $test[] = '2.2.6';
142        function phpgwapi_upgrade2_2_6()
143        {
144                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.8';
145                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
146        }
147        $test[] = '2.2.8';
148        function phpgwapi_upgrade2_2_8()
149        {
150                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.2.10';
151                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
152        }       
153        $test[] = '2.2.10';
154        function phpgwapi_upgrade2_2_10()
155        {
156                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.3.0';
157                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
158        }       
159        $test[] = '2.3.0';
160        function phpgwapi_upgrade2_3_0()
161        {
162                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.4.0';
163                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
164        }
165        $test[] = '2.4.0';
166        function phpgwapi_upgrade2_4_0()
167        {
168                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.4.1';
169                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
170        }
171
172        $test[] = '2.4.1';
173        function phpgwapi_upgrade2_4_1()
174        {
175                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.4.2';
176                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
177        }
178    $test[] = '2.4.2';
179    function phpgwapi_upgrade2_4_2()
180    {
181            $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.5.0';
182            return $GLOBALS['setup_info']['phpgwapi']['currentver'];
183    }
184 
185    $test[] = '2.5.0';
186        function phpgwapi_upgrade2_5_0()
187        {
188                $GLOBALS['setup_info']['phpgwapi']['currentver'] = '2.5.1';
189                global $setup_info,$phpgw_setup;
190                $phpgw_setup->oProc->query("ALTER TABLE phpgw_access_log ALTER COLUMN ip TYPE character varying(255) ");
191 
192                return $GLOBALS['setup_info']['phpgwapi']['currentver'];
193        }
194     
195
196?>
Note: See TracBrowser for help on using the repository browser.