Changeset 6207


Ignore:
Timestamp:
05/16/12 10:42:21 (8 years ago)
Author:
wmerlotto
Message:

Ticket #2557 - A instalacao do dialog deve ser a primeira coisa e deve ser feito automaticamente.

Location:
trunk/INSTALL
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/INSTALL/arquivos/scripts/aux.sh

    r6202 r6207  
    1  
    21# Funcoes auxiliares de todo o instalador 
    32 
     3# Monta um dialog para que o usuario insira a senha. 
     4# Depois grava a informacao em uma variavel global "LDAP_PWD". 
    45get_pass () 
    56{ 
     
    2223} 
    2324 
     25# Monta um dialog para que o usuario insira a organizacao e dominio 
     26# Depois grava as informacoes em variaveis globais 
    2427get_org () 
    2528{ 
     
    4649} 
    4750 
    48  
  • trunk/INSTALL/expressoInstall.sh

    r6075 r6207  
    4747[ $UID != 0 ] && { echo "Este script deve ser executado como superusuario (root) ou com sudo"; exit 1; } 
    4848 
     49# Instala o dialog 
     50# Se o arquivo existir, eh Debian ou variante ( ls /etc/*[-_]{release,version} ) 
     51if [ -f /etc/lsb-release ]  
     52then 
     53        apt-get -y install dialog || { echo "Falha ao instalar o dialog! Por favor, instale manualmente."; exit 1; } 
     54else 
     55        yum -y install dialog || { echo "Falha ao instalar o dialog! Por favor, instale manualmente."; exit 1; } 
     56fi 
     57 
    4958# Telas da instalacao 
    5059BACKTITLE="Instalação do ExpressoLivre versão $VERSAO" 
Note: See TracChangeset for help on using the changeset viewer.