Ticket #1271 (closed defeito: fixed)

Opened 10 years ago

Last modified 10 years ago

Corpo de email apresenta tags de comentário html em IE8

Reported by: rafaelraymundo Owned by: rafaelraymundo
Priority: normal Milestone: Expresso 2.2
Component: ExpressoMail Version: branch 2.2
Severity: média Keywords: SERPRO 2.2 UNIFICA prognus caixa
Cc: WorkGroup:

Description

Comentários HTML são apresentados no corpo dos emails em navegadores IE. Isso ocorre quando, após o início desses comentários (<!--), não possuem espaço em branco.

É apresentado como texto no Internet Explorer Ex.: <!--Teste123

Funciona corretamente Ex.: <!-- Teste123

Portanto é necessário adicionar um espaço em branco após essas tags.

Change History

comment:1 follow-up: ↓ 2 Changed 10 years ago by wmerlotto

  • Keywords prognus caixa added

Rafael, este ticket não está relacionado com este outro: #783?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 10 years ago by rafaelraymundo

Replying to wmerlotto:

Rafael, este ticket não está relacionado com este outro: #783?

Pois eh.. semelhante, mas o primeiro comentário do Zapa "Este problema é critico para usuários que recebem emails de fora do expresso..." Esse bug se refere a emails internos tbm. Todos os Internet Explorers mostram os comentários caso não tenha espaço em branco. Fiz um commit [3242] com uma solução semelhante a do diogenes que comentou nesse outro ticket sua solução.

comment:3 in reply to: ↑ 2 Changed 10 years ago by wmerlotto

Replying to rafaelraymundo:

Replying to wmerlotto:

Rafael, este ticket não está relacionado com este outro: #783?

Pois eh.. semelhante, mas o primeiro comentário do Zapa "Este problema é critico para usuários que recebem emails de fora do expresso..." Esse bug se refere a emails internos tbm. Todos os Internet Explorers mostram os comentários caso não tenha espaço em branco. Fiz um commit [3242] com uma solução semelhante a do diogenes que comentou nesse outro ticket sua solução.

Então, esta solução resolve uma situação. Acabei encontrando uma outra, onde depois de receber um e-mail de "fora" o usuário do Expresso encaminha/responde este e-mail e o problema dos "endif" acaba acontecendo no outlook. Por favor, dê uma olhada no patch de anexei no ticket #783.

comment:4 follow-up: ↓ 5 Changed 10 years ago by rafaelraymundo

Blza! Esse patch resolveu nossa questão por aqui. Podemos remover o [3242], commitar o patch e fechar os dois tickets. Quer fazer mais testes?

comment:5 in reply to: ↑ 4 ; follow-up: ↓ 6 Changed 10 years ago by wmerlotto

Replying to rafaelraymundo:

Blza! Esse patch resolveu nossa questão por aqui. Podemos remover o [3242], commitar o patch e fechar os dois tickets. Quer fazer mais testes?

Por mim está ok! Só não fiz o commit do patch antes pq gostaria que mais alguém o testasse. Alguém mais deseja avaliar o patch?

comment:6 in reply to: ↑ 5 Changed 10 years ago by rafaelraymundo

Quer que eu commite por aqui? Acho que mais ninguém vai testar...

Replying to wmerlotto:

Replying to rafaelraymundo:

Blza! Esse patch resolveu nossa questão por aqui. Podemos remover o [3242], commitar o patch e fechar os dois tickets. Quer fazer mais testes?

Por mim está ok! Só não fiz o commit do patch antes pq gostaria que mais alguém o testasse. Alguém mais deseja avaliar o patch?

comment:7 Changed 10 years ago by wmerlotto

Pode fazer o commit então.

comment:8 Changed 10 years ago by rafaelraymundo

  • Status changed from new to closed
  • Resolution set to fixed

Implementado em [3250] - Corrige endif tanto no Expresso quanto no Outlook. Vide patch do ticket #783

Atualizado branches/2.2/expressoMail1_2/inc/class.imap_functions.inc.php

Note: See TracTickets for help on using tickets.