Ticket #2398 (new melhoria) — at Initial Version

Opened 11 years ago

Last modified 10 years ago

Compatibilizar com PHP >= 5.3

Reported by: wmerlotto Owned by: wmerlotto
Priority: baixa Milestone: Expresso 2.5.0
Component: API Version: trunk
Severity: média Keywords: prognus php 5.3 5.4
Cc: WorkGroup:

Description

Verificar os logs gerados pelo PHP e executar as seguintes ações:

  1. Minimizar as incompatibilidades do tipo "PHP Notice" apontadas no log;
  2. Minimizar as incompatibilidades do tipo "PHP Warning" apontadas no log;
  3. Minimizar as incompatibilidades do tipo "PHP Strict standards" apontadas no log;

Acessar a  documentação de migração de versão do PHP e compatibilizar o código atual do Expresso com a versão 5.3 do PHP. Estes são alguns exemplos de alterações necessárias para compatibilizar o código com PHP-5.3:

ereg ('xxx', ..)   POR preg_match ('/xxx/', ..)
eregi ('xxx', ..)  POR preg_match ('/xxx/i', ..)
split ('xxx', ..)  POR preg_split ('/xxx/', ..)
spliti ('xxx', ..) POR preg_split ('/xxx/i', ..)
session_register (...) POR nada (1)

Ticket da Prognus:  #1210

Note: See TracTickets for help on using tickets.