Ticket #385 (closed defeito: invalid)

Opened 12 years ago

Last modified 12 years ago

Firefox trava após mover mensagem

Reported by: wmerlotto Owned by: alguem
Priority: média Milestone:
Component: ExpressoMail Version: 1.2
Severity: Keywords: expressomail firefox cpu
Cc: niltonneto WorkGroup:

Description

Em minha instalação do Expresso (direto do SVN) está ocorrendo algo estranho, pois geralmente após mover uma mensagem (seja pelo link "mover" ou arrastando-a) o firefox dá um pico no uso da CPU por alguns segundos (uns 5s), inviabilizando o uso das outras abas até a normalização da CPU.

Já monitorei o servidor em busca de alguma pista mas não encontrei nada. Seu funcionando, no servidor, é normal.

Alguém já notou algo assim?

Attachments

Captura_da_tela-1.png Download (109.0 KB) - added by amuller 12 years ago.
50 mil emails

Change History

comment:1 follow-up: ↓ 2 Changed 12 years ago by amuller

Não consegui reproduzir nem no Firefox 3.0.1 nem no 2.0.0.17. Será que vai aparecer mais alguem?

comment:2 in reply to: ↑ 1 Changed 12 years ago by wmerlotto

Replying to amuller:

Não consegui reproduzir nem no Firefox 3.0.1 nem no 2.0.0.17. Será que vai aparecer mais alguem?

Realmente não sei... Estou utilizando o Firefox 3.0.5, mas esse problema já aconteceu em outras versões do firefox.

Eu acho que pode ser algo relacionado com a quantidade de mensagens. Tenho 1,5GB de quota, com 80% em uso e mais de 800 mensagens na caixa de entrada. A quantidade de mensagens poderia influenciar?

comment:3 follow-up: ↓ 4 Changed 12 years ago by amuller

Ah! sim! Isso pode influenciar sim. Vou fazer uns testes aqui e já volto a postar, valeu cara.

comment:4 in reply to: ↑ 3 Changed 12 years ago by niltonneto

Replying to amuller:

Ah! sim! Isso pode influenciar sim. Vou fazer uns testes aqui e já volto a postar, valeu cara.

Com certeza influencia. Toda operação que chama a função refresh (Javascript/AJAX), falando a grosso modo, faz um diff do que tem de mensagens no cliente (JS) e o que tem no servidor (PHP), para atualizar a lista de mensagens (retirar ou adicionar mensagem da lista).

Acho que deve ser isso.....

Changed 12 years ago by amuller

50 mil emails

comment:5 follow-up: ↓ 6 Changed 12 years ago by amuller

Eu testei com 50 mil emails como na figura e não consegui reproduzir ainda

comment:6 in reply to: ↑ 5 Changed 12 years ago by wmerlotto

Replying to amuller:

Eu testei com 50 mil emails como na figura e não consegui reproduzir ainda

Fiz o seguinte teste:

  1. Criei uma nova pasta na caixa de entrada;
  2. Movi 700 mensagens (das 800 que tinha) da caixa de entrada para esta pasta;

Até agora o problema não ocorreu novamente... Será que alguma outra informação dos e-mails (cabeçalho, assunto, tamanho, ...) pode ter influenciado para este problema ocorrer com meus 800 e-mails e não acontecer com seus 50mil?

comment:7 in reply to: ↑ description ; follow-up: ↓ 8 Changed 12 years ago by rodsouza

Realizei diversos testes e não consegui simular o que foi descrito. Inclusive foi realizado teste no servidor de produção onde utilizo 90% da cota, e mesmo nesse caso nada de diferente ocorreu!

Isso ainda procede?

comment:8 in reply to: ↑ 7 Changed 12 years ago by wmerlotto

Replying to rodsouza:

Realizei diversos testes e não consegui simular o que foi descrito. Inclusive foi realizado teste no servidor de produção onde utilizo 90% da cota, e mesmo nesse caso nada de diferente ocorreu!

Isso ainda procede?

Depois que movi as mensagens da caixa de entrada, conforme descrito anteriormente, o problema não voltou a ocorrer. Creio que é melhor fechar o ticket, já que ninguém mais se manifestou. Se o problema voltar a ocorrer, reiniciamos a discussão...

comment:9 Changed 12 years ago by rodsouza

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.