Ticket #475 (closed melhoria: fixed)

Opened 12 years ago

Last modified 11 years ago

Permitir o Expresso carregue diversos templates sem perda de funcionalidade

Reported by: amuller Owned by: amuller
Priority: grave Milestone: Expresso 2.0
Component: API Version: trunk
Severity: Keywords: template tema expresso2
Cc: amuller WorkGroup:

Description

Implementação/estudo sobre os templates no Expresso, utilizando a API do Egroupware. Retirar códigos com caminhos embutidos que impedem o funcionamento.

Attachments

agenda.png Download (5.0 KB) - added by wmerlotto 11 years ago.
Screenshot de um agendamento. Alguns ícones não estão sendo carregados, tanto no tema antigo (celepar) quanto nos novos.

Change History

comment:1 in reply to: ↑ description Changed 12 years ago by niltonneto

Replying to amuller:

Implementação/estudo sobre os templates no Expresso, utilizando a API do Egroupware. Retirar códigos com caminhos embutidos que impedem o funcionamento.

Essa ocorrência é de extrema importância para esse momento, pois iremos definir nos próximos dias, o novo tema padrão para a versão oficial do Expresso. Dessa forma, quem quiser continuar com o tema atual, ou utilizar outro tema, não terá problema algum.

comment:2 Changed 12 years ago by amuller

Os objetivos são:

  • Possibilitar que as cores e figuras sejam carregadas nos templates e não nos códigos.
  • Se possível evitar que uma modificação no expresso necessite de modificação em todos os templates.

comment:3 Changed 11 years ago by niltonneto

  • Version changed from Celepar (companies/celepar) to SandBox (sandbox)

Está disponível para testes no sandbox "preparacao_novos_templates".
:

  • Implementada preparação do código para tornar flexível os templates em [773]
  • Adicionado novo template "Foz do Iguaçu" em [774]
  • Adicionado arquivos faltantes dos commits anteriores [775]

comment:4 Changed 11 years ago by niltonneto

  • Adicionado novo template "Canyon" em [776] e [777].

comment:5 Changed 11 years ago by niltonneto

  • Adicionado novo template "Azul" em [778].

comment:6 follow-up: ↓ 14 Changed 11 years ago by amuller

Também registrar aqui que o template do setup precisa ser revisto

comment:7 Changed 11 years ago by niltonneto

  • Version changed from SandBox (sandbox) to Trunk (trunk)

Merge efetuado no Trunk, dividido em duas revisões:
[790] - Modificação para tornar flexível a utilização de múltiplos templates
[791] - Adição de novos templates (Azul, Canyon e Fozi)

comment:8 follow-up: ↓ 21 Changed 11 years ago by wmerlotto

Estou utilizando o código do trunk, revisão [794], com o seguinte ambiente:

  • Debian Etch, com os pacotes padrões (php, apache, ...);
  • Firefox 3.0.10

Notei alguns bugs, como:

  1. Ao abrir uma mensagem e clicar no botão apagar (agora na parte de baixo), é retornada a seguinte mensagem: Nenhuma mensagem foi selecionada e a mensagem não é apagada. Ainda é possível apagar a mensagem selecionando-a pela lista;
  2. As mensagens de alterta, erro, ..., exibidas no topo do Expresso (no lugar do nome do usuário) ao serem exibidas alteram a formatação da página, deslocando toda lista de e-mails... Era para ser assim mesmo? Essa mensagem de alerta não teria que ter o mesmo tamanho do nome do usuário, para não criar essa movimentação?

Se notar mais alguma coisa, reportarei neste ticket...

comment:9 Changed 11 years ago by amuller

Eu testei no Firefox 3.0.1 e 3.0.9 no Windows e nenhum dele apresentou os problemas relatados. Vou continuar testando.

comment:10 Changed 11 years ago by wmerlotto

Bom, vc está utilizando o código do trunk mesmo? E mais um detalhe, estou utilizando Ubuntu 9.04.

comment:11 Changed 11 years ago by niltonneto

Testei no Trunk e no Companies/Celepar? e realmente os dois itens acontecem. Estou FF 3.0.9 do Ubuntu.

comment:12 follow-up: ↓ 16 Changed 11 years ago by wmerlotto

Notei outro problema, mas não sei é realmente relacionado com o templates. Se não for, me avise que abro outro ticket.

Ao abrir um e-mail com imagens, as mesmas são bloqueadas até que seja clicado no botão (ou link) "show images from...". Com o tema "azul" eu clico neste botão e nada acontece, as imagens do e-mail não são carregadas. Com o tema celepar (padrão), o botão nem é "clicavél"...

A plataforma testada ainda é a mesma, ff-3.0.10 no Ubuntu 9.04.

comment:13 Changed 11 years ago by amuller

  • Milestone set to Expresso Mail 1.234

comment:14 in reply to: ↑ 6 ; follow-up: ↓ 39 Changed 11 years ago by niltonneto

Replying to amuller:

Também registrar aqui que o template do setup precisa ser revisto

Implementado em [796].

comment:15 Changed 11 years ago by niltonneto

Corrigido em [798] o caminho do arquivo 'folderopen.png' que estava hardcoded.

comment:16 in reply to: ↑ 12 ; follow-up: ↓ 17 Changed 11 years ago by niltonneto

Replying to wmerlotto:

Notei outro problema, mas não sei é realmente relacionado com o templates. Se não for, me avise que abro outro ticket.

Ao abrir um e-mail com imagens, as mesmas são bloqueadas até que seja clicado no botão (ou link) "show images from...". Com o tema "azul" eu clico neste botão e nada acontece, as imagens do e-mail não são carregadas. Com o tema celepar (padrão), o botão nem é "clicavél"...

A plataforma testada ainda é a mesma, ff-3.0.10 no Ubuntu 9.04.

Corrigido em [800], conforme ticket #38.

comment:17 in reply to: ↑ 16 Changed 11 years ago by wmerlotto

Replying to niltonneto:

Corrigido em [800], conforme ticket #38.

Realmente esta funcionalidade está funcionando muito bem, inclusive nos dois temas! Obrigado!

comment:18 Changed 11 years ago by wmerlotto

Ao acessar a agenda, com o tema azul, é exibido a seguinte mensagem no fim da página:

Template Error: loadfile: num_dias is not a valid handle.
Backtrace: Template::loadfile / Template::subst / Template::parse / uicalendar::output_template_array / uicalendar::footer / include / common::phpgw_footer / uicalendar::week / ExecMethod
Halted.

Com o tema padrão, celepar, esta mensagem não é exibida.Ainda estou utilizando o mesmo ambiente, Ubuntu 9.04 e FF-3.0.10.

comment:19 Changed 11 years ago by niltonneto

Corrigido em [803] o caminho da pasta de templates no arquivo "filters.js".

comment:20 Changed 11 years ago by niltonneto

Corrigido em [814] o caminho da pasta de templates, além de alguns ajustes nas variáveis de estilo.

comment:21 in reply to: ↑ 8 ; follow-up: ↓ 25 Changed 11 years ago by wmerlotto

Replying to wmerlotto:

Notei alguns bugs, como:

  1. Ao abrir uma mensagem e clicar no botão apagar (agora na parte de baixo), é retornada a seguinte mensagem: Nenhuma mensagem foi selecionada e a mensagem não é apagada. Ainda é possível apagar a mensagem selecionando-a pela lista;
  2. As mensagens de alterta, erro, ..., exibidas no topo do Expresso (no lugar do nome do usuário) ao serem exibidas alteram a formatação da página, deslocando toda lista de e-mails... Era para ser assim mesmo? Essa mensagem de alerta não teria que ter o mesmo tamanho do nome do usuário, para não criar essa movimentação?

Só para complementar, quando estou visualizando um e-mail, nenhum dos links (apagar, mover, imprimir, marcar como spam, ...) de baixo funciona.

comment:22 Changed 11 years ago by amuller

Wilian: o Nilton ta fazendo o sync ainda. Pode ter coisa que faltou

comment:23 Changed 11 years ago by niltonneto

Removido em [819] templates que nunca foram utilizados pelo Expresso.

comment:24 Changed 11 years ago by niltonneto

Removido em [820] arquivos desnecessários.

comment:25 in reply to: ↑ 21 ; follow-up: ↓ 26 Changed 11 years ago by niltonneto

Replying to wmerlotto:

Replying to wmerlotto:

Notei alguns bugs, como:

  1. Ao abrir uma mensagem e clicar no botão apagar (agora na parte de baixo), é retornada a seguinte mensagem: Nenhuma mensagem foi selecionada e a mensagem não é apagada. Ainda é possível apagar a mensagem selecionando-a pela lista;
  2. As mensagens de alterta, erro, ..., exibidas no topo do Expresso (no lugar do nome do usuário) ao serem exibidas alteram a formatação da página, deslocando toda lista de e-mails... Era para ser assim mesmo? Essa mensagem de alerta não teria que ter o mesmo tamanho do nome do usuário, para não criar essa movimentação?

Só para complementar, quando estou visualizando um e-mail, nenhum dos links (apagar, mover, imprimir, marcar como spam, ...) de baixo funciona.

Corrigido em [827] os problemas relatados por William. Correção do caminho de algumas imagens.

comment:26 in reply to: ↑ 25 ; follow-up: ↓ 27 Changed 11 years ago by wmerlotto

Replying to niltonneto:

Corrigido em [827] os problemas relatados por William. Correção do caminho de algumas imagens.

Os botões estão funcionando perfeitamente agora. Só o alerta que ainda continua com problemas...

comment:27 in reply to: ↑ 26 ; follow-up: ↓ 28 Changed 11 years ago by niltonneto

Replying to wmerlotto:

Replying to niltonneto:

Corrigido em [827] os problemas relatados por William. Correção do caminho de algumas imagens.

Os botões estão funcionando perfeitamente agora. Só o alerta que ainda continua com problemas...

Você está se referindo ao item 2, que move o layout pra baixo quando algum alerta é exibido né?

comment:28 in reply to: ↑ 27 ; follow-up: ↓ 29 Changed 11 years ago by wmerlotto

Replying to niltonneto:

Você está se referindo ao item 2, que move o layout pra baixo quando algum alerta é exibido né?

Isso mesmo.

comment:29 in reply to: ↑ 28 ; follow-up: ↓ 32 Changed 11 years ago by niltonneto

Replying to wmerlotto:

Replying to niltonneto:

Você está se referindo ao item 2, que move o layout pra baixo quando algum alerta é exibido né?

Isso mesmo.

Foi corrigido em [831].

comment:30 Changed 11 years ago by niltonneto

Corrigido em [835] o estilo do link "salvar" mensagem.

comment:31 Changed 11 years ago by niltonneto

Corrigido em [838] mais alterações sobre o estilo do link "salvar" mensagem, além da inclusão da função purgeCache().

comment:32 in reply to: ↑ 29 Changed 11 years ago by wmerlotto

Replying to niltonneto:

Foi corrigido em [831].

Realmente foi corrigido. Está funcionado muito bem agora.

Mas a agenda ainda apresenta os problemas de template:

Template Error: loadfile: num_dias is not a valid handle.
Backtrace: Template::loadfile / Template::subst / Template::parse / uicalendar::output_template_array 
/ uicalendar::footer / include / common::phpgw_footer / uicalendar::week / ExecMethod
Halted.

Ao adicionar um novo agendamento, as imagens dos botões (adicionar/remover participantes) também não estão aparecendo. A busca por usuários, no LDAP, também não está funcionando. Estou utilizando a revisão [844], com o tema Azul.

comment:33 follow-up: ↓ 34 Changed 11 years ago by niltonneto

Mais erros (testado em ambiernte de homologação, apontando pro Trunk):

1 - Os avisos (write_msg) de "Movido, removido, enviado, etc", continuam deslocando para baixo e para cima todo layout quando aparecem e somem.

2 - No template "celepar", quando o cursor está sobre os filtros de relevância "Todas", "Respondidas", etc, no rodapé, o filtro selecionado muda seu css, retirando o sublinhado e negrito.

comment:34 in reply to: ↑ 33 ; follow-up: ↓ 35 Changed 11 years ago by niltonneto

Replying to niltonneto:

Mais erros (testado em ambiernte de homologação, apontando pro Trunk):

1 - Os avisos (write_msg) de "Movido, removido, enviado, etc", continuam deslocando para baixo e para cima todo layout quando aparecem e somem.

2 - No template "celepar", quando o cursor está sobre os filtros de relevância "Todas", "Respondidas", etc, no rodapé, o filtro selecionado muda seu css, retirando o sublinhado e negrito.

Ambiente cliente: Ubuntu 8.04 com Firefox 3.0.10

comment:35 in reply to: ↑ 34 Changed 11 years ago by amuller

Replying to niltonneto:

Replying to niltonneto:

Mais erros (testado em ambiernte de homologação, apontando pro Trunk):

1 - Os avisos (write_msg) de "Movido, removido, enviado, etc", continuam deslocando para baixo e para cima todo layout quando aparecem e somem.

resolvido em [848]

comment:36 Changed 11 years ago by niltonneto

  • Status changed from new to closed
  • Resolution set to fixed

comment:37 follow-up: ↓ 38 Changed 11 years ago by wmerlotto

E os erros da agenda? Não serão analisados os outros módulos? Este ticket é só para o ExpressMail??

comment:38 in reply to: ↑ 37 Changed 11 years ago by alexandrecorreia

  • Milestone changed from Expresso Mail 1.234 to Expresso 1.2

Replying to wmerlotto:

E os erros da agenda? Não serão analisados os outros módulos? Este ticket é só para o ExpressMail??

Vou atrelar esse ticket ao Marco Expresso 1.2, já que não é somente ExpressoMail?.

comment:39 in reply to: ↑ 14 ; follow-up: ↓ 41 Changed 11 years ago by alexandrecorreia

Replying to niltonneto:

Replying to amuller:

Também registrar aqui que o template do setup precisa ser revisto

Implementado em [796].

Corrigido em [853] caminho da figura "orange-ball.png" do setup.

comment:40 Changed 11 years ago by alexandrecorreia

  • Cc amuller added
  • Status changed from closed to reopened
  • Resolution fixed deleted

Reaberto porque ainda existe problema nos demais módulos.

comment:41 in reply to: ↑ 39 Changed 11 years ago by wmerlotto

Replying to alexandrecorreia:

Corrigido em [853] caminho da figura "orange-ball.png" do setup.

Me parece (me corrija se estiver errado) que muitas das alterações são relacionadas aos caminhos das imagens. Aí, executei este comando em busca de alterações que ainda devem ser feitas (seguindo sua última alteração):

cd /var/www/expresso
egrep -rin "(\.\.\/phpgwapi\/templates|idots|idsociety|jerryr|literati|prisma)" * | egrep -v "(.svn|setup\/phpgw)"

Espero que facilite... :D

comment:42 Changed 11 years ago by amuller

Resolvido problema do calendar em [855] [854]

comment:43 follow-up: ↓ 44 Changed 11 years ago by wmerlotto

Pessoal, não sei vcs já viram, mas a página de adição de agendamento não está funcionando corretamente, pois:

  1. As imagens dos botões não estão aparecendo;
  2. Não é possível buscar por usuários para adicioná-los como participantes (consigo selecionar a organização);
  3. Não é possível adicionar participantes externos;

Estou utilizando o código do trunk, na revisão [857], com FF 3.0.10 no Ubuntu 9.04.

comment:44 in reply to: ↑ 43 ; follow-up: ↓ 45 Changed 11 years ago by niltonneto

Replying to wmerlotto:

Pessoal, não sei vcs já viram, mas a página de adição de agendamento não está funcionando corretamente, pois:

  1. As imagens dos botões não estão aparecendo;
  2. Não é possível buscar por usuários para adicioná-los como participantes (consigo selecionar a organização);
  3. Não é possível adicionar participantes externos;

Estou utilizando o código do trunk, na revisão [857], com FF 3.0.10 no Ubuntu 9.04.

Isso ocorre em qualquer template? Eu tive que fazer uma correção em [856], conforme ultimo comentário no ticket #509.

comment:45 in reply to: ↑ 44 Changed 11 years ago by wmerlotto

Replying to niltonneto:

Isso ocorre em qualquer template? Eu tive que fazer uma correção em [856], conforme ultimo comentário no ticket #509.

No tema padrão, celepar, está funcionando corretamente mas no tema azul e foz do iguaçu não. Mas já não estava funcionando antes (da alteração [856] ou anterior).

comment:46 follow-up: ↓ 47 Changed 11 years ago by amuller

Wilian: r858

comment:47 in reply to: ↑ 46 Changed 11 years ago by wmerlotto

Replying to amuller:

Wilian: r858

Amuller, aparentemente está da mesma forma, a tela de inclusão de agendamentos ainda está com problemas. Verifiquei os logs do apache e encontrei estes erros:

[error] File does not exist: /var/www/expresso/calendar/templates/default/js, referer: http://webmail/index.php?menuaction=calendar.uicalendar.add&date=20090520
[error] File does not exist: /var/www/expresso/calendar/templates/default/images/sent.gif, referer: http://webmail/index.php?menuaction=calendar.uicalendar.add&date=20090520
[error] File does not exist: /var/www/expresso/calendar/templates/default/images/add.png, referer: http://webmail/index.php?menuaction=calendar.uicalendar.add&date=20090520
[error] File does not exist: /var/www/expresso/calendar/templates/default/images/rem.png, referer: http://webmail/index.php?menuaction=calendar.uicalendar.add&date=20090520

Se precisar de outras informações, por favor, me avise.

comment:48 follow-up: ↓ 49 Changed 11 years ago by amuller

Ta certo faltou coisa no commit. Agora sim com r862

comment:49 in reply to: ↑ 48 ; follow-up: ↓ 50 Changed 11 years ago by wmerlotto

Replying to amuller:

Ta certo faltou coisa no commit. Agora sim com r862

Agora vc removeu imagens demais, inclusive para o tema padrão (celepar). Segue em anexo um screenshot de um agendamento.

Na página de adição de agendamento, a consulta por participantes não está funcionando (somente com os novos temas, azul, fozi, ...).

Changed 11 years ago by wmerlotto

Screenshot de um agendamento. Alguns ícones não estão sendo carregados, tanto no tema antigo (celepar) quanto nos novos.

comment:50 in reply to: ↑ 49 Changed 11 years ago by rafaelraymundo

  • Milestone changed from Expresso 1.2 to Calendar 1.0

Replying to wmerlotto:

Replying to amuller:

Ta certo faltou coisa no commit. Agora sim com r862

Agora vc removeu imagens demais, inclusive para o tema padrão (celepar). Segue em anexo um screenshot de um agendamento.

Na página de adição de agendamento, a consulta por participantes não está funcionando (somente com os novos temas, azul, fozi, ...).

Usando o template Serpro, com o calendar da comunidade unificado percebi que a revisão #858 que retira códigos amarrados a um template quebram os botões de Adicionar/Remover? e Avisar Partic Externos. Caso essas linhas usem GLOBALS ao ivés de SESSION esse erro não ocorre. No cód abaixo referente a "class.uicalendar.inc.php" ele retorna o botão Adicionar corretamente.

'<button type="button" onClick="javascript:add_user();"><img src="calendar/templates/'.$GLOBALSphpgw_info?user?preferences?common?template_set?.'/images/add.png" style="vertical-align: middle;" >&nbsp;'.lang("Add").'</button>'. ...

Na implementação da revisão #858 da forma abaixo, os botões == não carregam == corretamente

... '<button type="button" onClick="javascript:add_user();"><img src="calendar/templates/'.$_SESSIONphpgw_info?calendaruser?preferences?common?template_set?.'/images/add.png" style="vertical-align: middle;" >&nbsp;'.lang("Add").'</button>'.

>>

Mas caso permaneça como GLOBALS isso pode ter algum impacto nos templates que estão sendo implementados.

comment:51 Changed 11 years ago by rafaelraymundo

Corrigido em [933] - Código alterado de Globals para Session, mas os links das três imagens comentados anteriormente permanecem como Globals

comment:52 Changed 11 years ago by amuller

As revisões 938 939 940 941 944 945 retiram os templates e transformam em temas e adiciona o login azul feito por designers da celepar

comment:53 Changed 11 years ago by rafaelraymundo

Muller, Essas alterações no login impactaram nas nossas modificações. Necessitamos separar a lógica dos logins e commitar no trunk da comunidade, para evitar problemas desse tipo.

ok?

comment:54 Changed 11 years ago by rafaelraymundo

Corrigido em [948] [949] - Lógica do login foi separada em: /phpgwapi/templates/celepar/login_celepar.php /phpgwapi/templates/azul/login_azul.php /phpgwapi/templates/default/login_default.php

expresso/login.php identifica qual template utilizar

comment:55 Changed 11 years ago by niltonneto

Corrigido em [953] [954] rodapé do login azul (template e imagens).

comment:56 follow-up: ↓ 57 Changed 11 years ago by rafaelraymundo

É interessante prever que da forma que está a caixa de login não será expandida na inserção de um captcha e de sua caixa de texto. O ideal seria que essa caixa de login fosse uma div com uma imagem de fundo.

comment:57 in reply to: ↑ 56 Changed 11 years ago by niltonneto

  • Priority changed from media to grave
  • Milestone changed from Calendar 1.0 to Expresso 2.0

Replying to rafaelraymundo:

É interessante prever que da forma que está a caixa de login não será expandida na inserção de um captcha e de sua caixa de texto. O ideal seria que essa caixa de login fosse uma div com uma imagem de fundo.

Concordo contigo. O tamanho da caixa tinha que ser dinâmico, mas o WebDesign? encarregado desse novo layout entregou dessa forma pra nós. Vou verificar com ele.

comment:58 Changed 11 years ago by amuller

commit 963 implementa caixa com tamanho variável

comment:59 follow-up: ↓ 60 Changed 11 years ago by niltonneto

1 - Adaptar código javascript para suportar duas classes CSS (tr_msg_read e tr_msg_read2) na grade da lista de mensagens. O objetivo é tornar o produto final bem perto do layout proposto. Para não impactar nos demais templates, como o atual, será acresentado um alias 'tr_msg_read2' na mesma classe CSS 'tr_msg_read'.

2 - Adaptar resultado da busca com mesmo formato.

3 - Importante: Por padrão, as linhas da lista de mensagens terão sempre como CSS 'tr_msg_read' e 'tr_msg_read2', alternadamente. Para mensagems não-lidas, será acrescentada a classe 'tr_msg_unread'. Para mensagens importantes, a classe 'tr_flagged_msg'. E por fim, para mensagens selecionadas, a classe 'selected_msg'.

comment:60 in reply to: ↑ 59 Changed 11 years ago by niltonneto

Replying to niltonneto:

1 - Adaptar código javascript para suportar duas classes CSS (tr_msg_read e tr_msg_read2) na grade da lista de mensagens. O objetivo é tornar o produto final bem perto do layout proposto. Para não impactar nos demais templates, como o atual, será acresentado um alias 'tr_msg_read2' na mesma classe CSS 'tr_msg_read'.

2 - Adaptar resultado da busca com mesmo formato.

3 - Importante: Por padrão, as linhas da lista de mensagens terão sempre como CSS 'tr_msg_read' e 'tr_msg_read2', alternadamente. Para mensagems não-lidas, será acrescentada a classe 'tr_msg_unread'. Para mensagens importantes, a classe 'tr_flagged_msg'. E por fim, para mensagens selecionadas, a classe 'selected_msg'.

Implementado em [976]

comment:61 Changed 11 years ago by niltonneto

Corrigido em [992] problema na figura de fundo da div "content_folders" no template azul.

comment:62 Changed 11 years ago by niltonneto

Corrigido em [993] problema da borda do checkbox, que sempre aparece no Internet Explorer.

comment:63 Changed 11 years ago by niltonneto

Revertido em [994] codificação das flags das mensagens na lista draw_box, devido à problemas de transparência das imagens.

comment:64 Changed 11 years ago by amuller

Melhorias [1049] [1054] [1055]

comment:65 Changed 11 years ago by amuller

phpgwapi/temas

Página criada para esclarecimento.

comment:66 follow-up: ↓ 67 Changed 11 years ago by niltonneto

Adicionado em [1077:1081] template azul no módulo Ajuda.

comment:67 in reply to: ↑ 66 Changed 11 years ago by niltonneto

Replying to niltonneto:

Adicionado em [1077:1081] template azul no módulo Ajuda.

 Arquivos e pastas adicionadas.

comment:68 Changed 11 years ago by niltonneto

Modificado em [1083] o template do setup.

comment:69 Changed 11 years ago by niltonneto

Modificado em  [1093:1096]a ajustes na página inicial.

comment:70 follow-up: ↓ 81 Changed 11 years ago by niltonneto

Alterado em [1100] toda implementação referente link "Sugestões" do Expresso, para usar multiplos templates. Além disso, foi criado template azul para o mesmo. Correções no arquivo de idioma pt-BR.

comment:71 Changed 11 years ago by amuller

comment:72 Changed 11 years ago by amuller

Correção do logo no ie [1133]

comment:73 Changed 11 years ago by niltonneto

  • Status changed from reopened to new

AlexandreMuller?, favor fazer as devidas modificações para alterarmos as pastas templates "azul" para "default", e de "celepar" para "classico". Lembre-se que os links simbólicos também deverão ser alterados dentro do "azul", já que apontam para o "celepar".

comment:74 Changed 11 years ago by amuller

r1151 implementa a mudança

comment:75 Changed 11 years ago by niltonneto

O link "Fonte da Mensagem" não existe mais no novo template. Muitos usuários terão dificuldade em "descobrir" que o link "Exportar" de dentro da mensagem faz a mesma coisa. Favor recolocar o link ao lado de "Responder a todos sem histórico".

comment:76 follow-up: ↓ 77 Changed 11 years ago by amuller

[1208] Volta com dois links na parte superior e inferior.

comment:77 in reply to: ↑ 76 Changed 11 years ago by niltonneto

Replying to amuller:

[1208] Volta com dois links na parte superior e inferior.

Replicado no Branch 2.0 em [1221].

comment:78 follow-up: ↓ 79 Changed 11 years ago by niltonneto

O fundo do ícone do módulo atual não está em destaque quando é carregado. Isto é percebido nos novos temas, já que possuem imagem diferente na classe 'navbar_butOut'.

comment:79 in reply to: ↑ 78 Changed 11 years ago by niltonneto

Replying to niltonneto:

O fundo do ícone do módulo atual não está em destaque quando é carregado. Isto é percebido nos novos temas, já que possuem imagem diferente na classe 'navbar_butOut'.

Corrigido no Trunk em [1215]. Replicado no Branch 2.0 em [1222].

comment:80 follow-up: ↓ 82 Changed 11 years ago by niltonneto

Imagens quebradas ao visualizar status do compromisso da agenda, conforme o  link dessa imagem. Muller, se puder verificar, agradeço.

comment:81 in reply to: ↑ 70 Changed 11 years ago by niltonneto

Replying to niltonneto:

Alterado em [1100] toda implementação referente link "Sugestões" do Expresso, para usar multiplos templates. Além disso, foi criado template azul para o mesmo. Correções no arquivo de idioma pt-BR.

Para os links "Ajuda" e "Sugestões", as pastas "azul" e "celepar" foram movidas para "default" e "classic" respectivamente. Corrigido em  1248 a 1253.

comment:82 in reply to: ↑ 80 Changed 11 years ago by niltonneto

Replying to niltonneto:

Imagens quebradas ao visualizar status do compromisso da agenda, conforme o  link dessa imagem. Muller, se puder verificar, agradeço.

Corrigido em [1306].

comment:83 follow-up: ↓ 84 Changed 11 years ago by amuller

Correção de problema da função fora de escritório ocasionado por remoção de código das preferências [1308]

comment:84 in reply to: ↑ 83 Changed 11 years ago by niltonneto

Replying to amuller:

Correção de problema da função fora de escritório ocasionado por remoção de código das preferências [1308]

Esse problema se refere ao ticket #485.

comment:85 follow-up: ↓ 87 Changed 11 years ago by niltonneto

Podemos fechar esse ticket?

comment:86 Changed 11 years ago by niltonneto

Corrigido em [1325] problema do campo texto rico, referente ao termo de aceito no Admin.

comment:87 in reply to: ↑ 85 Changed 11 years ago by niltonneto

  • Status changed from new to closed
  • Resolution set to fixed

Replying to niltonneto:

Podemos fechar esse ticket?

OK, acredito que não temos mais nenhum problema grave em relação a essa implementação.

Note: See TracTickets for help on using tickets.