Ticket #483 (closed defeito: invalid)

Opened 12 years ago

Last modified 11 years ago

Requisições presas no Mozilla

Reported by: amuller Owned by: ninguem
Priority: pequena Milestone: Expresso 2.2
Component: ExpressoMail Version: trunk
Severity: Keywords: requisições lentidão
Cc: niltonneto WorkGroup:

Description

Algumas vezes o Expresso dispara requisições que aparentemente não terminam e não tem função, no Mozilla. A mais fácil de relatar foi resolvida, na abertura de nova mensagem ao carregar o iframe algum evento estava disparando uma requisição que ficava parada.

Porém muitas outras ainda estão acontecendo em lugares distintos. O objetivo do ticket reporta-las e corrigi-las.

Change History

comment:1 Changed 12 years ago by amuller

  • Component changed from API to ExpressoMail
  • Milestone set to Expresso Mail 1.234

comment:2 Changed 12 years ago by rodsouza

O fato é que não é necessariamente uma requisição que é realizada.

Em circunstâncias desconhecidas a barra (ou o ícone) de carregar ficam como se o navegador estivesse processando uma requisição.

Esse fato ocasiona diversas reclamações por parte dos usuários pois eles acreditam que o ExpressoMail? que está realizando uma requisição que não termina.

Um determinado usuário alegava que a funcionalidade de "Salvar Automático" demorava tempo superior a 30 segundos, a alegação baseava-se no ícone de carregar que permanecia durante todo esse tempo como se estivesse sob uma requisição.

Em algumas dessas circunstâncias o navegador consome todo o recurso do CPU disponível.

Mas até que seja provado o contrário, isso não é defeito grave, senão o IE daqui um pouco será considerado um erro do ExpressoLivre? ... rsrsrsrrs. Alguém quer arrumar o IE?

comment:3 Changed 12 years ago by amuller

  • Version changed from Trunk (trunk) to Celepar (companies/celepar)
  • Milestone changed from Expresso Mail 1.234 to Expresso Mail 1.235

Vou reclassificar, pois não foi resolvido

comment:4 Changed 12 years ago by niltonneto

  • Priority changed from grave to pequena
  • Status changed from new to closed
  • Version changed from Celepar (companies/celepar) to Trunk (trunk)
  • Resolution set to fixed
  • Milestone Expresso Mail 1.235 deleted

Corrigido em [813], quando o iframe da aba de nova mensagem é redimensionado.

comment:5 Changed 12 years ago by niltonneto

  • Status changed from closed to reopened
  • Resolution fixed deleted

O ticket foi reaberto porque a revisão [813] não resolve todos os problemas relatados aqui.

comment:6 follow-up: ↓ 7 Changed 12 years ago by gustavoliden

Tem dois outros locais que o mesmo erro foi detectado:

  1. Ao editar duas mensagens ao mesmo tempo e tentar salvar/enviar as duas. Ocorre um erro de javascript e o "carregando....." fica indefinidamente.
  1. Ao cancelar a leitura de uma mensagem criptografada quando o pin é requisitado.

comment:7 in reply to: ↑ 6 Changed 12 years ago by wmerlotto

Replying to gustavoliden:

Tem dois outros locais que o mesmo erro foi detectado:

  1. Ao editar duas mensagens ao mesmo tempo e tentar salvar/enviar as duas. Ocorre um erro de javascript e o "carregando....." fica indefinidamente.

Isto também acontece por aqui, tanto no Firefox-3.0 quanto Firefox-3.5.

comment:8 follow-up: ↓ 9 Changed 12 years ago by amuller

Esse ticket não se referia a estas requisições (Que são disparadas pelo conector). Se referia a outras requisições malucas que o firefox disparava na criação de iframes.

comment:9 in reply to: ↑ 8 ; follow-up: ↓ 11 Changed 12 years ago by gustavoliden

Replying to amuller:

Esse ticket não se referia a estas requisições (Que são disparadas pelo conector). Se referia a outras requisições malucas que o firefox disparava na criação de iframes.

Blza, essas requisições malucas eu nunca vi, no entanto os usuários reclamam bastante desse "carregando...".

Vou commitar a correção. Pode ser nesse trac ou é preciso criar outro?

comment:10 Changed 12 years ago by amuller

Se possível cria outro ticket pra não misturar as soluções

comment:11 in reply to: ↑ 9 Changed 11 years ago by wmerlotto

  • Milestone set to Expresso 2.1

Replying to gustavoliden:

Vou commitar a correção. Pode ser nesse trac ou é preciso criar outro?

Gustavo, vc chegou a realizar este commit?

comment:12 Changed 11 years ago by amuller

  • Status changed from reopened to closed
  • Resolution set to wontfix

comment:13 Changed 11 years ago by amuller

  • Status changed from closed to reopened
  • Resolution wontfix deleted

comment:14 Changed 11 years ago by amuller

  • Owner changed from amuller to NINGUEM
  • Status changed from reopened to new

comment:15 Changed 11 years ago by niltonneto

  • Owner changed from NINGUEM to ninguem

comment:16 Changed 11 years ago by niltonneto

  • Status changed from new to closed
  • Resolution set to invalid

O problema não acontece mais. Talvez fosse um bug do Firefox com resizeWindow, já que não fazia nenhuma requisição em background. Apenas aparecia "Carregando" ao redimensionar janela.

Note: See TracTickets for help on using tickets.