Ticket #731 (closed defeito: fixed)

Opened 11 years ago

Last modified 11 years ago

Tipo de Assinatura Rico não é carregado no inicio da pagina

Reported by: david.ianakiara Owned by: lucas.dacosta
Priority: média Milestone: Expresso 2.0.2
Component: ExpressoMail Version: branch 2.0
Severity: Keywords: texto rico preferences simples
Cc: WorkGroup:

Description

nas preferencias, ao salvar o tipo de assinatura como "texto rico" e carregar a página novamente, o tipo de formatação da assinatura é carregado como texto simples.

Change History

comment:1 follow-up: ↓ 2 Changed 11 years ago by wmerlotto

David, este problema é similar ao reportado no ticket #654?

comment:2 in reply to: ↑ 1 Changed 11 years ago by lucas.dacosta

  • Owner changed from david.ianakiara to lucas.dacosta
  • Status changed from new to assigned

Pelo que eu pude verificar agora, o problema é na hora de carregar o editor de texto rico (FCKEditor) isso só aconteceu no Firefox. No firebug apareceu o seguinte:

this.EditingArea is undefined
[Break on this error] var FCK_StartupValue;FCK.Events=new FCKE...true;FCK.Events.FireEvent("OnFocus");}}\n

Estranho que isso não acontece quando seleciona Texto Simples e depois volta para Texto Rico Vou verificar isso neste ticket, pois não é o mesmo problema do ticket #654

Replying to wmerlotto:

David, este problema é similar ao reportado no ticket #654?

comment:3 Changed 11 years ago by david.ianakiara

O erro que encontrei aqui era na função getTypeSignature que faz um laço entre os elementos do tipo 'select' pra pegar o valor do combo tipo de assinatura.

comment:4 follow-up: ↓ 6 Changed 11 years ago by david.ianakiara

além disso encontrei um erro na navegação das abas, quando você seleciona as preferencias do expressoMail estando na aba Preferencias obrigatórias, está sendo carregada a caixa de assinatura, e acredito que não deveria estar sendo carregada.

comment:5 Changed 11 years ago by david.ianakiara

Resolvido na revisao [1611]

comment:6 in reply to: ↑ 4 Changed 11 years ago by lucas.dacosta

Para este erro acho q foi aberto um ticket, estou procurando aqui.

Replying to david.ianakiara:

além disso encontrei um erro na navegação das abas, quando você seleciona as preferencias do expressoMail estando na aba Preferencias obrigatórias, está sendo carregada a caixa de assinatura, e acredito que não deveria estar sendo carregada.

comment:7 follow-up: ↓ 9 Changed 11 years ago by david.ianakiara

hum... e aí como é que faz então?

comment:8 Changed 11 years ago by david.ianakiara

está se referindo ao ticket #711?

comment:9 in reply to: ↑ 7 Changed 11 years ago by lucas.dacosta

Vou comentar lá no #711 que você corrigiu o link

Replying to david.ianakiara:

hum... e aí como é que faz então?

comment:10 Changed 11 years ago by david.ianakiara

Pode fechar aqui já então?

comment:11 Changed 11 years ago by lucas.dacosta

Sim pode fechar

comment:12 Changed 11 years ago by david.ianakiara

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:13 Changed 11 years ago by niltonneto

  • Status changed from closed to reopened
  • Resolution fixed deleted

Pessoal, podemos replicar essa correção no Branch 2.0? É que aqui na Celepar poderemos ter problemas com nossos usuários caso essa correção entre apenas na 2.1

comment:14 follow-up: ↓ 15 Changed 11 years ago by wmerlotto

Não vejo problema em replicar esta correção. Na verdade, qualquer coisa que não está "funcionando" corretamente (e que já foi corrigido no trunk), ou seja, impede o usuário de utilizar a funcionalidade, deveria ser replicado para o branch.

comment:15 in reply to: ↑ 14 Changed 11 years ago by niltonneto

  • Keywords texto rico preferences simples added
  • Status changed from reopened to closed
  • Version changed from trunk to branch 2.0
  • Resolution set to fixed
  • Milestone changed from Expresso 2.1 to Expresso 2.0.2

Replying to wmerlotto:

Não vejo problema em replicar esta correção. Na verdade, qualquer coisa que não está "funcionando" corretamente (e que já foi corrigido no trunk), ou seja, impede o usuário de utilizar a funcionalidade, deveria ser replicado para o branch.

Ok! Replicado no Branch 2.0 em [1663]. Vou alterar o marco já que precisa ser publicado na próxima versão.

comment:16 follow-up: ↓ 17 Changed 11 years ago by wmerlotto

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone changed from Expresso 2.0.2 to Expresso 2.0.3

Esta correção criou um efeito colateral, conforme reportado no fórum. Revisão [1611] revertida no trunk em [1873].

comment:17 in reply to: ↑ 16 Changed 11 years ago by wmerlotto

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Milestone changed from Expresso 2.0.3 to Expresso 2.0.2

Replying to wmerlotto:

Esta correção criou um efeito colateral, conforme reportado no fórum. Revisão [1611] revertida no trunk em [1873].

Desfazendo o erro, já que a regra? não permite reabrir tickets de milestones fechados.

comment:18 Changed 11 years ago by david.ianakiara

Resolvido na revisão [1890]

Note: See TracTickets for help on using tickets.