Ticket #732 (closed defeito: fixed)

Opened 11 years ago

Last modified 10 years ago

Filtro "fora do escritório" não funciona

Reported by: lavoisier.vieira Owned by: alguem
Priority: média Milestone: Expresso 2.2
Component: ExpressoMail Version: trunk
Severity: média Keywords: [serpro]
Cc: WorkGroup:

Description (last modified by rafaelraymundo) (diff)

Ao habilitar a opção do filtro "Fora do Escritório" este não retorna email para o remetente informando a mensagem configurada de ausência.

Para reproduzir: 1.Va em ferramentas, editar filtros; 2.Clique em "nova regra" da opção "Fora do escritório"; 3.Entre com sua mensagem de ausencia e confirme; 4.Envie uma mensagem atraves de outra conta - esta conta não recebe o email automático configurado.

Change History

comment:1 Changed 11 years ago by diogenesduarte

Testamos isso aqui e verificamos que esse problema só acontece com o usuário expresso-admin. Para todas as outras contas a funcionalidade não apresentou problemas em nossos testes. Isso é proposital?

comment:2 Changed 11 years ago by niltonneto

Tem a ver com a localização do diretório sieve do expresso-admin. A pasta padrão do sieve dos usuários fica em /var/spool/sieve/{letrainicialdologin}. O expresso-admin é o único usuário que fica em /var/spool/sieve/global, e aí, na hora que alguém manda uma mensagem pra ele, dá o seguinte erro no cyrus: "sieve script /var/spool/sieve/e/expresso-admin/defaultbc doesn't exist: No such file or directory". Eu acho tem a ver com o expresso-admin ser o admin do cyrus.

comment:3 follow-up: ↓ 4 Changed 10 years ago by rafaelraymundo

  • Severity set to média

Criei dois usuários para não testar com o expresso-admin, ambos no grupo default.

O teste do filtro fora do escritório funcionou corretamente no primeiro teste, mas após isso ele não funciona mais. O email é enviado, mas não retorna a msg definida no filtro fora do escritório. Testado com Firefox e Expresso_Branch22 revisão 3254.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 10 years ago by niltonneto

Replying to rafaelraymundo:

Criei dois usuários para não testar com o expresso-admin, ambos no grupo default.

O teste do filtro fora do escritório funcionou corretamente no primeiro teste, mas após isso ele não funciona mais. O email é enviado, mas não retorna a msg definida no filtro fora do escritório. Testado com Firefox e Expresso_Branch22 revisão 3254.

Rafael, veja se não tem a ver com o que eu alertei no ticket #1255.

comment:5 in reply to: ↑ 4 Changed 10 years ago by rafaelraymundo

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Replying to niltonneto:

Replying to rafaelraymundo:

Criei dois usuários para não testar com o expresso-admin, ambos no grupo default.

O teste do filtro fora do escritório funcionou corretamente no primeiro teste, mas após isso ele não funciona mais. O email é enviado, mas não retorna a msg definida no filtro fora do escritório. Testado com Firefox e Expresso_Branch22 revisão 3254.

Rafael, veja se não tem a ver com o que eu alertei no ticket #1255.

Blza Nilton, sendo uma configuração do Sieve, essa funcionalidade está Ok.

Ticket fechado.

Note: See TracTickets for help on using tickets.