Ticket #8 (closed defeito: wontfix)

Opened 10 years ago

Last modified 9 years ago

Filtro falha quando campo de assunto contém SOMENTE 1 palavra

Reported by: amuller Owned by: amuller
Priority: pequena Milestone:
Component: ExpressoMail Version: 1.0
Severity: Keywords: codificação filtro assunto
Cc: WorkGroup:

Description

Relacionado ao #4, o que acontece é quando o campo assunto contém 1 palavra só fica numa codificação estranha.

Change History

comment:1 Changed 10 years ago by amuller

  • Type changed from tarefa to defeito

Por exemplo Ações sozinho fica

Subject: =?iso-8859-1?B?Qef1ZXM=?=

Por outro lado, no meio de uma frase ele fica certo.

comment:3 Changed 9 years ago by amuller

  • Owner changed from alguem to amuller

comment:4 Changed 9 years ago by amuller

  • Status changed from new to assigned

comment:5 Changed 9 years ago by amuller

  • Status changed from assigned to closed
  • Resolution set to wontfix
<?php
echo "\n";

echo iconv_mime_decode("=?iso-8859-1?B?Qef1ZXM=?=",  0, "UTF-8")."\n";
echo "=?iso-8859-1?B?Qef1ZXM=?=";

$preferences = array(
        "output-charset" => "ISO-8859-1",
        "input-charset" => "UTF-8",
        "line-length" => 76,
        "line-break-chars" => "\n"
);
echo "\n";
$preferences["scheme"] = "B";
echo iconv_mime_encode("Subject", "Ações", $preferences);
echo "\n";
?>

Esse código gera e des-gera a codificação que o Outlook usa. Porém essa alteração deveria ser feita no Sieve. Pois a criação de várias regras iria causar muitos outros problemas. Esse bug fica inválido pois o expresso não pode tratar o problema que deve ser tratado no Sieve.

Note: See TracTickets for help on using tickets.