Ticket #938 (closed defeito: fixed)

Opened 12 years ago

Last modified 11 years ago

Falha ao importar compromisso ICS (Microsoft CDO Library)

Reported by: niltonneto Owned by: wmerlotto
Priority: média Milestone: Expresso 2.0.6
Component: Calendar Version: branch 2.0
Severity: Keywords: importar ICS agenda CDO
Cc: pedro@… WorkGroup:

Description

Caso um usuário receba um compromisso anexado por email e clique no botão de importar compromisso, ou tente importá-lo diretamente pela agenda, a ação não é concluída. Essa falha ocorre com arquivos enviados pelo Microsoft Exchange, que usa Collaboration Data Objects (CDO) como biblioteca para gerar o compromisso no formato ICS.

Attachments

meeting.ics Download (1.7 KB) - added by niltonneto 12 years ago.
ICS Example
outlook.diff Download (4.4 KB) - added by wmerlotto 11 years ago.
Patch para a v2.0.x do Expresso. Ainda precisa ser testado.

Change History

Changed 12 years ago by niltonneto

ICS Example

comment:1 Changed 12 years ago by niltonneto

O parâmetro "ATTENDEE;ROLE" pode ser usado para preencher o campo "Participantes Externos" do compromisso no Expresso. Já o parâmetro "ORGANIZER" guarda informações de quem está convidando, e que normalmente também é um participante externo.

comment:2 Changed 12 years ago by wmerlotto

  • Milestone set to Expresso 2.2

Changed 11 years ago by wmerlotto

Patch para a v2.0.x do Expresso. Ainda precisa ser testado.

comment:3 Changed 11 years ago by wmerlotto

  • Owner changed from alguem to wmerlotto

Pessoal, fiz vários testes com as modificações propostas no patch em anexo e não encontrei problemas. Há algum impedimento em aplicá-lo no branch2.0?

comment:4 Changed 11 years ago by niltonneto

William, eu não tive tempo de testar. Mas pode aplicar sim, e amarrar este ticket ao marco 2.0.6 e version "Branch 2.0".

comment:5 Changed 11 years ago by wmerlotto

  • Status changed from new to closed
  • Version changed from trunk to branch 2.0
  • Resolution set to fixed
  • Milestone changed from Expresso 2.2 to Expresso 2.0.6

Atualizado no branch2.0 [2654] e no trunk [2655].

comment:6 Changed 11 years ago by niltonneto

Testei no Branch 2.0 e funcionou belezinha!

Note: See TracTickets for help on using tickets.