Changes between Version 1 and Version 2 of Instalacao/AtualizarExpresso


Ignore:
Timestamp:
11/12/12 01:22:33 (8 years ago)
Author:
wmerlotto
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Instalacao/AtualizarExpresso

    v1 v2  
    1313  * Proceda em horários sem ou de baixa utilização; 
    1414 
    15 A cada nova versão, podem ser adicionados novos requisitos, tanto de softwares como de configurações adicionais. Portanto, fique atento e siga a risca a documentação aqui especificada! 
     15A cada nova versão, podem ser adicionados novos pré-requisitos, tanto de softwares como de configurações adicionais. Portanto, fique atento e siga a risca a documentação aqui especificada! 
    1616 
    1717=== Baixando e instalando o pacote da nova versão === 
    18 Primeiramente, veja se seu ambiente suporta os '''requisitos mínimos''' da [wiki:versions/OLD versão] que está pretendendo utilizar. Caso seu ambiente não esteja condizente com os '''requisitos mínimos''', esteja ciente que: 
    19  1. Seu Expresso poderá não funcionar corretamente, em uma ou mais funcionalidades; 
     18Primeiramente, veja se seu ambiente suporta os '''pré-requisitos''' da [wiki:versions/OLD versão] que está pretendendo utilizar. Caso seu ambiente não esteja condizente com os pré-requisitos, esteja ciente que: 
     19 1. Seu Expresso poderá não funcionar corretamente, seja com uma ou mais funcionalidades; 
    2020 2. A comunidade e principalmente os desenvolvedores não lhe darão suporte para os problemas identificados; 
    2121 
    22 Com os requisitos mínimos atendidos: 
     22Com os pré-requisitos atendidos: 
    2323 1. Faça o download da versão desejada do Expresso Livre [http://www.expressolivre.org/html/expressolivre/index.php?page=downloads aqui]. Preferencialmente, faça o download no diretório '''/root'''; 
    2424 2. Descompacte o pacote: 
     
    2929 {{{ 
    3030cp /var/www/expresso/header.inc.php /root/expresso/ 
    31 cp ... 
     31cp /var/www/expresso/prototype/config/{PostgreSQL.srv,Sieve.srv,SMTP.srv,OpenLDAP.srv,CalDAV.srv} /root/expresso/prototype/config/ 
    3232}}} 
    3333 4. Ajuste as permissões dos arquivos e diretórios, para que o servidor HTTP possa acessar os mesmos: 
     
    4343 
    4444=== Ajustando os novos requisitos da nova versão === 
     45Verifique, na [[wiki:versions/OLD página da versão] que você está realizando a instalação, as modificações necessárias para que a mesma funcione corretamente. 
     46 
     47Após estes ajustes, é muito importante atualizar o script do cron utilizado em seu ambiente. Para isto, verifique o arquivo contido no novo pacote: 
     48{{{ 
     49# Altere o nome do atual script 
     50mv /etc/cron.d/expresso /etc/cron.d/expresso-ANTIGO 
     51# Copie o novo script 
     52cp /root/expresso/INSTALL/arquivos/expresso-cron /etc/cron.d/expresso 
     53}}} 
     54Este script foi feito para basicamente dois tipos de sistemas operacionais (e seus derivados): CentOS e Debian. Portanto é importante, após copiá-lo, alterá-lo conforme o sistema operacional utilizado. Para isto, basta remover os comentários (#CENTOS ou #DEBIAN). 
    4555 
    4656=== Atualizando os módulos e linguagens ===