Changes between Version 2 and Version 3 of Servicos/Funambol/Desenvolvimento/CustomizarMaven


Ignore:
Timestamp:
11/10/09 11:30:33 (9 years ago)
Author:
lucas.dacosta
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Servicos/Funambol/Desenvolvimento/CustomizarMaven

    v2 v3  
    1 == Alguns comandos para o Maven (http://maven.apache.org): 
    2 1- Primeiro instale o maven, na verdade é só descompactar o arquivo em uma pata depois colocar o bin no PATH. 
    3 2- Depois execute mvn --version para confirmar se está tudo certo. 
    4 3- Na pasta contrib/psync tem um arquivo pom.xml, os comandos devem ser executados lá. 
    5 4- Para executar a compilação do projeto: mvn install 
    6 5- O maven cria a pasta target e coloca o arquivo .s4j lá. 
     1== Alguns comandos para o Maven (http://maven.apache.org): == 
     21- Primeiro instale o maven, na verdade é só descompactar o arquivo em uma pata depois colocar o bin no PATH.[[BR]] 
     32- Depois execute mvn --version para confirmar se está tudo certo.[[BR]] 
     43- Na pasta contrib/psync tem um arquivo pom.xml, os comandos devem ser executados lá.[[BR]] 
     54- Para executar a compilação do projeto: mvn install[[BR]] 
     65- O maven cria a pasta target e coloca o arquivo .s4j lá.[[BR]] 
    77 
    88 
    9 == Para utilização com Eclipse: 
    10 1- Primeiro veja se os passos acimas foram executas com sucesso. 
    11 2- Altere o arquivo pom.xml para o maven gerar um projeto no eclipse. 
    12 3- Apague ou comente a linha <packaging>s4j</packaging> e salve 
    13 4- Execute o comando: mvn eclipse:eclipse 
    14 5- Volte a linha <packaging>s4j</packaging> e salve 
    15 6- No eclipse abra o menu Arquivo (File) > Importar (Import) > Existing Projects into Workspace (Projeto já existente) > Next. 
    16 7- Selecione a pasta onde está o psync/pom.xml Ok e Terminar (Finish) 
     9== Para utilização com Eclipse: == 
     101- Primeiro veja se os passos acimas foram executas com sucesso.[[BR]] 
     112- Altere o arquivo pom.xml para o maven gerar um projeto no eclipse.[[BR]] 
     123- Apague ou comente a linha <packaging>s4j</packaging> e salve[[BR]] 
     134- Execute o comando: mvn eclipse:eclipse[[BR]] 
     145- Volte a linha <packaging>s4j</packaging> e salve[[BR]] 
     156- No eclipse abra o menu Arquivo (File) > Importar (Import) > Existing Projects into Workspace (Projeto já existente) > Next.[[BR]] 
     167- Selecione a pasta onde está o psync/pom.xml Ok e Terminar (Finish)[[BR]]