Ticket #1135 (closed tarefa: fixed)

Opened 9 years ago

Last modified 9 years ago

Criar branches do Expresso 2.2

Reported by: amuller Owned by: amuller
Priority: média Milestone:
Component: API Version: branch 2.2
Severity: média Keywords: branches 2.2
Cc: WorkGroup:

Description

Criar o branches do Expresso 2.2 apartir da revisão 1998, a adicionar as alterações do Expresso 2.0 desta revisão (1998) até a atual. Mais alterações do trunk que não impactam muito no código

Change History

comment:1 Changed 9 years ago by amuller

r3016 cria o branches 2.2 r3018 aplica as alterações do branches 2.0 no branches 2.2 r3019 adiciona o filemanager

comment:2 follow-up: ↓ 3 Changed 9 years ago by niltonneto

A revisão [3031] ajusta para a versão 2.2, a atualização do header.inc.php, setup dos módulos e API. A versão Expresso 2.2 permite atualização a partir do Expresso 1.2. Quem tiver versão muito antiga do Expresso, terá que instalar primeiro a 2.0 e depois a 2.2.

comment:3 in reply to: ↑ 2 Changed 9 years ago by wmerlotto

Replying to niltonneto:

A versão Expresso 2.2 permite atualização a partir do Expresso 1.2. Quem tiver versão muito antiga do Expresso, terá que instalar primeiro a 2.0 e depois a 2.2.

Versão muito antiga é anterior a 1.2 ou é a própria 1.2? Acho que antes disso o versionamento era por módulo...

comment:4 Changed 9 years ago by niltonneto

Versão anterior à 1.2. Na verdade, eu deixei compatível pelo menos, com a última versão (módulos e API) que está do repositório SVN, em Branches/1.2. Antes disso, o versionamento era por módulo mesmo.

comment:5 follow-up: ↓ 6 Changed 9 years ago by amuller

Eu acho ruim disso é que a instalação pela web (que deveria ser a principal) não funciona mais direito, porque ela utiliza estas atualizações para popular o banco. Se o cara remove um módulo e instala denovo, ou instala todos pelo setup do expresso fica tudo estragado.

O ideal era não ter um dump do postgres inteiro, mas sim 1 por módulo que seria usado também nesta instalação web. Ou tirar o setup web porque ele pode destruir o expresso do administrador sem chance dele recuperar (só fazendo outro dump do expresso inteiro)

comment:6 in reply to: ↑ 5 Changed 9 years ago by wmerlotto

Replying to amuller:

Eu acho ruim disso é que a instalação pela web (que deveria ser a principal) não funciona mais direito, porque ela utiliza estas atualizações para popular o banco. Se o cara remove um módulo e instala denovo, ou instala todos pelo setup do expresso fica tudo estragado.

O ideal era não ter um dump do postgres inteiro, mas sim 1 por módulo que seria usado também nesta instalação web. Ou tirar o setup web porque ele pode destruir o expresso do administrador sem chance dele recuperar (só fazendo outro dump do expresso inteiro)

Concordo contigo Muller. Creio que o ideal seria utilizar a própria estrutura de atualização dos módulos (tables_update.inc.php?) para fazer a instalação e atualização...

comment:7 follow-up: ↓ 8 Changed 9 years ago by niltonneto

Também concordo com Muller. É preciso rever o setup mesmo, já que muita gente também tenta instalar o Expresso pela Web, já com os demais serviços funcionando, só querendo usá-los com Expresso.

comment:8 in reply to: ↑ 7 Changed 9 years ago by niltonneto

Replying to niltonneto:

Também concordo com Muller. É preciso rever o setup mesmo, já que muita gente também tenta instalar o Expresso pela Web, já com os demais serviços funcionando, só querendo usá-los com Expresso.

Este assunto pode ser discutido e implementado no Ticket #707.

comment:9 Changed 9 years ago by amuller

r3104 faz atualização de tabelas para o filemanager

comment:11 Changed 9 years ago by niltonneto

  • Version changed from trunk to branch 2.2

r3173 corrige atualização (setup) do módulo EmailAdmin?.

comment:12 Changed 9 years ago by amuller

  • Status changed from new to closed
  • Resolution set to fixed

comment:13 Changed 9 years ago by viani

Realizado merge do ramo /trunk/workflow/, da revisão 1990 até 3166, no ramo /branches/2.2/workflow/, em [3167]

Note: See TracTickets for help on using tickets.