Ticket #1631 (closed defeito: fixed)

Opened 11 years ago

Last modified 11 years ago

Sistema trava ao tentar ler uma mensagem com imagem no arquivamento local

Reported by: yasmin.kamal Owned by: diogenesduarte
Priority: normal Milestone: Expresso 2.2.0-alpha
Component: ExpressoMail Version: branch 2.2
Severity: média Keywords:
Cc: WorkGroup: Centro de Testes

Description

Plataforma de Teste: FF3 - Win

O sistema não está abrindo a mensagem com imagem no arquivamento local, o sistema acaba travando o expresso.

Caso de teste:  http://testlink.expressolivre.org/lib/execute/execSetResults.php?version_id=7300&level=testcase&id=2102&tplan_id=2664&setting_build=11&setting_platform=4

Change History

comment:1 Changed 11 years ago by niltonneto

  • Milestone changed from Expresso 2.2.0 to Expresso 2.2.0-alpha

comment:2 Changed 11 years ago by diogenesduarte

  • Owner changed from ninguem to diogenesduarte

comment:3 Changed 11 years ago by diogenesduarte

  • Status changed from new to closed
  • Resolution set to fixed

Resolvido em [3870]. O problema estava em um update no banco do sqlite, pois vinha um campo contendo aspas simples. Para resolver substituímos, antes do update, as mesmas por duas aspas simples, que é o escape delas no sqlite. No entanto se no texto vierem duas aspas simples, nada é substituído. Substituímos apenas as aspas simples solitárias, caso o tratamento já tenha sido feito em alguma parte da string anteriormente.

Note: See TracTickets for help on using tickets.