Ticket #891 (closed melhoria: fixed)

Opened 11 years ago

Last modified 10 years ago

Desenvolvimento de corretor ortográfico.

Reported by: zapa Owned by: paulo-roberto
Priority: normal Milestone: Expresso 2.2
Component: ExpressoMail Version: branch 2.2
Severity: média Keywords: SERPRO 2.2 UNIFICA
Cc: WorkGroup: Inovação

Description (last modified by niltonneto) (diff)

Estamos iniciando desenvolvimento da funcionalidade de correção ortográfica pelo expresso.

Change History

comment:1 Changed 11 years ago by niltonneto

  • Description modified (diff)

Criado em [2164] um sub-branch do ExpressoMail? (versão Trunk) para a respectiva implementação.

comment:2 Changed 11 years ago by zapa

  • Owner changed from zapa to paulo-roberto

comment:3 Changed 10 years ago by rafaelraymundo

  • Keywords SERPRO 2.2 UNIFICA added
  • Version changed from trunk to branch 2.2
  • Component changed from API to ExpressoMail
  • Severity set to média

comment:4 in reply to: ↑ description ; follow-up: ↓ 5 Changed 10 years ago by brunocosta

  • Status changed from new to closed
  • Resolution set to fixed

Implementado no branch 2.2 na revisão [3400]

Foi adicionada a preferência (no minhas preferências) 'Quer usar o corretor ortográfico no editor de emails?' que controla a utilização ou não da funcionalidade no editor de email.

Para que o corretor funcione é necessário instalar os seguintes pacotes (testado no debian Lenny): aspell, libaspell-dev, libaspell15, aspell-pt-br, aspell-es, aspell-en, php5-pspell, libpspell-dev.

comment:5 in reply to: ↑ 4 Changed 10 years ago by eduardoalex

Bruno, meu velho, é interessante colocar a necessidade dessas dependências lá no wiki, pois fica mais fácil quando algu[em quiser utilizar a funcionalidade.

Replying to brunocosta:

Implementado no branch 2.2 na revisão [3400]

Foi adicionada a preferência (no minhas preferências) 'Quer usar o corretor ortográfico no editor de emails?' que controla a utilização ou não da funcionalidade no editor de email.

Para que o corretor funcione é necessário instalar os seguintes pacotes (testado no debian Lenny): aspell, libaspell-dev, libaspell15, aspell-pt-br, aspell-es, aspell-en, php5-pspell, libpspell-dev.

comment:6 Changed 10 years ago by joaquim.ferraz

Acho que deveríamos fechar o ticket após realizarmos ajustes no instalador. Ou é melhor já abrir um chamado para ajustar o instalador, referenciando esse ticket?

comment:7 Changed 10 years ago by niltonneto

  • Priority changed from pequena to normal
  • WorkGroup set to Inovação

É preciso implementar algum aviso para o administrador do Expresso, que tais pacotes são requeridos para utilizar a preferência que habilita o corretor ortográfico. Eu pessoalmente não concordo em habilitá-lo por padrão no instalador, já que é um componente a mais e não uma exigência para fazer funcionar o ExpressoMail?.

Note: See TracTickets for help on using tickets.