Ticket #1578 (closed defeito: fixed)

Opened 9 years ago

Last modified 9 years ago

Enviar mensagem com imagem no corpo do e-mail

Reported by: guilherme.silva Owned by: alexandrecorreia
Priority: normal Milestone: Expresso 2.2.4
Component: ExpressoMail Version: branch 2.2
Severity: média Keywords:
Cc: WorkGroup: Centro de Testes

Description

Após selecionar a imagem, o endereço dela fica no campo Anexo (como tivesse sido selecionada uma imagem anexa) e na parte inferior da página aparece a mensagem: "Concluído, com erro na oágina". Obs: o "botão Enviar" não é exibido.

Browser : Internet Explorer 7

 Caso de teste

Attachments

bug-mensagem-com-imagem.ogg Download (4.0 MB) - added by cesar.vianna 9 years ago.
Reprodução do BUG
image-mail-ie7.jpg Download (46.6 KB) - added by rodsouza 9 years ago.
preferencias-mail.jpg Download (104.5 KB) - added by cesar.vianna 9 years ago.
Preferências Expresso Mail

Change History

comment:1 follow-up: ↓ 3 Changed 9 years ago by diogenesduarte

Não tou conseguindo reproduzir...

comment:2 Changed 9 years ago by niltonneto

  • Milestone changed from Expresso 2.2.2 to Expresso 2.2.0-rc1

comment:3 in reply to: ↑ 1 Changed 9 years ago by rodsouza

Replying to diogenesduarte:

Não tou conseguindo reproduzir...



Idem.

comment:4 Changed 9 years ago by cesar.vianna

Segue vídeo em anexo com a reprodução do erro.

Notem que após inserir a imagem no CORPO da mensagem e tentar enviar é gerado um erro. Após, a mensagem é enviada sem a imagem.

Atentar para a plataforma: Internet Explorer!

Changed 9 years ago by cesar.vianna

Reprodução do BUG

comment:5 follow-up: ↓ 6 Changed 9 years ago by rodsouza

Um vídeo não adianta de nada!

O que realmente ajudaria é saber o que está interferindo, como por exemplo as preferências.

E ratificando, o erro não pode ser reproduzido pelo falta de informação.

Vide imagem do e-mail enviado com imagem.

Changed 9 years ago by rodsouza

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 7 Changed 9 years ago by cesar.vianna

Replying to rodsouza:

Rodrigo, favor solicitar informações pontuais para que possamos auxiliar. A intenção é que o vídeo demonstre os passos seguidos para gerar o bug, os dados utilizados como entradas e os erros resultantes.

Saber o que está interferindo é parte da solução do problema. Os testes tem como objetivo principal identificar o problema.

Em relação às preferências, segue imagem em anexo das preferências da conta utilizada.

Um vídeo não adianta de nada!

O que realmente ajudaria é saber o que está interferindo, como por exemplo as preferências.

E ratificando, o erro não pode ser reproduzido pelo falta de informação.

Vide imagem do e-mail enviado com imagem.

Changed 9 years ago by cesar.vianna

Preferências Expresso Mail

comment:7 in reply to: ↑ 6 Changed 9 years ago by cesar.vianna

Replying to cesar.vianna:

Replying to rodsouza:

Em tempo, já foi utilizado o ambiente de testes para tentar reproduzir o erro?

comment:8 follow-up: ↓ 9 Changed 9 years ago by rodsouza

Já solicitei inúmeras vezes o acesso ao ambiente de teste e nunca tive. Inclusive o acesso do Alexandre Correia foi revogado, assim não temos mais acesso.

Quanto a informações adicionais, todas as possibilidades que imaginei, tentei utilizar porém não tive sucesso, com isso não sei o que pode ser e por consequência não tenho como pedir informações extra com precisão. Além de que as mesmas deveriam estar inseridas na descrição do problema.

comment:9 in reply to: ↑ 8 Changed 9 years ago by cesar.vianna

Replying to rodsouza:

Rodrigo, para cadastro nos ambientes de teste podes enviar email pra mim cesar.vianna [ arroba ] serpro gov br ou através da lista de testes (disponível no TRAC).

Realmente não consegui identificar que fator pode estar influenciando para que o erro ocorra no ambiente de testes e não no seu. Independente do usuário utilizado, o erro é reproduzido em qualquer mensagem que seja inserida uma imagem.

comment:10 Changed 9 years ago by niltonneto

  • Owner changed from alguem to ninguem

comment:11 Changed 9 years ago by alexandrecorreia

  • Owner changed from ninguem to alexandrecorreia

Olá Cesar !!!

Vc pode enviar a mesma imagem que vc está anexando no vídeo ??? Vou tentar reproduzir seguindo seus passos, dentro do IE 7 !!!

Estou no aguardo !

comment:12 follow-up: ↓ 13 Changed 9 years ago by alexandrecorreia

Cesar !

Vc pode testar esta revisão ? Revisao [4379] !!

comment:13 in reply to: ↑ 12 Changed 9 years ago by cesar.vianna

Replying to alexandrecorreia:

Cesar !

Vc pode testar esta revisão ? Revisao [4379] !!

É necssário sair a TAG da 2.2.4 para testarmos.

comment:14 Changed 9 years ago by niltonneto

  • Status changed from new to closed
  • Resolution set to fixed

Teste exploratório teve o resultado esperado. Além disso, o ticket #1917 sincronizou a devida correção feita aqui.

Note: See TracTickets for help on using tickets.